Exploratory Testing - Jira add-on is either Disabled/Uninstalled

Follow this article if you’re seeing the below error while creating an issue using QMetry Test Management Exploratory plugin.

Jira Add-on is either Disabled/Uninstalled or please check your Jira credentials by logging into Jira

Cause

  • This issue occurs when the Jira credentials being used for authenticating the user by QMetry are not correct anymore as they may have expired or have been updated in Jira.

Solution

  • Authenticating with the correct Jira credentials in QMetry should fix this issue. Follow the steps below to update your credentials.

  1. Go to QMetry > Integration menu > Integrations > search for your "Integration URL" > click on gear/setting icon > Revoke Credentials. (see attached)

  2. Once revoked - click on the gear/setting icon again > Update Credentials > Enter your Jira credentials > Authenticate.

     

    • Provide Jira username and password in case of Server Jira.

    • Provide username and API token in case of Cloud Jira to authenticate the credentials.

Note:

  • When the user is logging an issue for the very first time from QMetry, the user is prompted to authenticate that operation by providing the Jira credentials. The pop-up does not appear afterward.

  • The above steps need to be repeated only if the user's Jira credentials have changed. In that case, the user needs to authenticate again with the updated Jira credentials in QMetry.

3. After successful authentication with Jira, the above-mentioned error while not appear anymore in the Exploratory Testing session while logging a defect.