Troubleshooting - Unable to tag users in comments / tagged user not receiving email

Symptoms:

  1. The user is unable to tag another user using “@” in QMetry fields - description, precondition, comment, and actual result.

  2. The tagged user is not able to receive any email notifications from QMetry.

  3. Test case execution summary by Execution Assignee report displays few users as "null"

Cause:

This occurs due to the following missing permissions/configurations.

  • Probable Reason 1: The user does not have the “Browse Project Permission” for the Jira project and is, therefore, unable to tag other users in the project.

  • Probable Reason 2: Insufficient/Missing permissions provided to user or group to the Atlassian add-ons on your Jira instance.

  • Probable Reason 3: You must have received the email, however, due to some email rules or settings it must be moved to some other folder or spam folder instead of your inbox.

Solution:

  1. Enable the below Jira project permissions in order to tag another user using “@” in QMetry fields:

    1. Browse Projects: The user is required to have the “Browse Projects” permission to be able to tag other users in the project. Navigate to Project Settings > Permissions > Browse Projects and check if the user is provided with this permission.

    2. Assign Issues: The user is required to have the Assign Issues permission to be able to assign/tag other users. in. Navigate to Project Settings > Permissions > Assign Issues and check if the user is provided with this permission.

    3. Assignable User: The user or user groups you want to tag should have Assignable User permission. These users will appear in the suggestion drop-down when you tag such users. Navigate to Project Settings > Permissions > Assignable User and check if the user is provided with this permission.

       

       

  2. Permissions and configurations required to receive email notifications when your username is tagged:
    The user and the “atlassian-addons-admin” group should have “Browse users and groupsglobal permission. This is mandatory and these groups are added by default when you install the QTM4J add-on. If they are missing, then add these groups to the permission by navigating to Jira settings > Global permissions > Browse users and groups. Refer to the screenshot below. Contact QMetry Support in case of any issues with tagging users.